Blue line under all uploaded images

Home Forums WordPress Themes – Premium Preference Blue line under all uploaded images

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #15170
    nigel arnold
    Member

    How do I remove the blue line that seems to appear under all images when they are inserted into the page ?

    #19936
    Sushil Adhikari
    Moderator

    Do you want the bottom border to be removed on “all” images or just select images?

    #19942
    nigel arnold
    Member

    I think I would like to know both if it is easy – sometimes the border looks ok with an image but other times maybe not so.

    I can get away with just being able to turn it off for selected images because then I have the choice of having it or not.

    #19944
    Sushil Adhikari
    Moderator

    To remove the borders altogether, you can do:

    img {border: none;}

    To target specific images, this gets a bit more tricky, but you can do that with a few ways. If it’s an image you are manually adding to a widget, post, or page, you can do an inline style on the tag like:

    <img class="alignleft" style="border:none;"

    ….etc. Make sure “style” is after the “class”.

    However, to show you where the border is being applied to, you can also choose which one to do the border:none with:

    .entry-thumbnail img,
    .img-intro img,
    .img-intro-left img,
    .img-intro-right img,
    .img-intro-none img,
    .imageborder,
    .contact-image img,
    .entry-attachment img,
    img.alignnone,
    img.alignright,
    img.alignleft,
    img.aligncenter,
    div.wp-caption img {
    	border-bottom:8px solid #78a5b6;
    }
    #19945
    nigel arnold
    Member

    Sorry I know nothing about scripting which I agree does not help !

    Anyway trying to do your option 2 – which look the easiest – I have uploaded a picture then gone into text view and added the code ….. style=”border:none into the code below but it has no effect ie the blue line is still there – am I on the right track or a million miles away ?

    #19946
    Sushil Adhikari
    Moderator

    No worries…Here is another possibility… to disable the border (or make it appear it is), if your images are on a white background, you can change the colour setting for the image border to white. Go to Appearance >> Customize >> Colours >> Image Border

    Are you using the child theme for Preference, or do you have Jetpack installed, or a plugin like Simple Custom CSS ?

    #19947
    nigel arnold
    Member

    Thanks now I understand it is a border I found this video which shows the change quiet well – just in case anybody else is as dumb as me on such matters ! ?

    https://www.youtube.com/watch?v=pwwhH-WQYzY

    Many thanks

    #15171
    Sushil Adhikari
    Moderator

    Hey…good job. I work with code so many times and rarely delve into the WordPress hidden functions, such as the advanced tab on the image window, I didn’t even know what style and class field was there :silly:

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.