Can’t upload my logo

Viewing 15 posts - 1 through 15 (of 17 total)
  • Author
    Posts
  • #14726

    Hi:

    Just started working with Celestial. Have tried every way I can think of to upload my logo.
    Will display as text, or the original Celestial logo, but upload button in the customize settings do not work, also can’t drop the file in drop box. My logo is PNG image 150px wide x 50px high.

    Any ideas?

    Thanks

    #19218
    Sushil Adhikari
    Moderator

    That is odd…something must be interfering with the upload function (a WordPress function). I just tried uploading a test logo on my local site and I was able to do it. I also remember someone last year had a similar issue as you are and it turned out it was a plugin they had installed, but I cannot remember what plugin it was.

    If possible, could you contact me with login details and I will try this out on your site with a test logo?

    #19219

    Hi:

    The only widgets I have installed other than the standard WordPress widgets are WP User Control Widget and the LayerSlider widget. I haven’t done any mods to WordPress or the themes. This also happened on the Celestial lite demo product I downloaded through WordPress. I’ve just started working with this and have only added LayerSlider.

    Unfortunately I can’t let you see it because it’s setup on my localhost WAMP server.. In the text logo, is there any way to change the font, or is it in the CSS file?

    Thanks

    #19220
    Sushil Adhikari
    Moderator

    best way to change fonts to specific elements is to use a font plugin because they offer a lot more flexibility. Was there something specific in the theme that you wanted to change the font to?

    Regarding the logo upload… I’m wondering if it’s being affected due to you being on WAMP. I think that was the issue with the other person last year because it seems familiar as I believe that was the culprit. I use XAMPP and just moments ago installed the Lite version as well a new install of Celestial Reloaded…both were able to upload a logo.

    #19221

    The font I use for my company documentation is Trebuchet MS. my text logo with the default template does not look good.

    Any suggestions for the Font widget?

    #19222
    Sushil Adhikari
    Moderator

    A popular one seems to be WP Google Fonts.

    For the font on the text logo (title) is found on line 355 that looks like this:

    h1#site-title a {
    font: italic 1.25em/0.75em merienda, georgia;
    text-decoration: none;
    }

    So if you do an override with the font plugin, you would target the h1#site-title a

    #19384

    Hi, I rebuilt my site on the production server. Fresh install of latest WordPress, re-installed and activated plugins and widgets.
    Still can’t upload my logo. On the customize section of theme, when I select My Logo, it does not let me add my logo file. It’s as if there is no link or button there.

    Also on font. I installed Google fonts and selected the fonts to use and selected Headings in the options, and theme will not use Google font, just defaults to the theme font..

    With everything I’ve tried it doesn’t look like a WordPress issue.

    What now?

    #19385
    Sushil Adhikari
    Moderator

    Before when someone had problems uploading a logo, it was due to a plugin they had…I cannot remember what plugin it was but it was affecting the customizer upload function (which incidentally is a WordPress function and not a theme). So here are a few tests for you….

    1. disable all plugins that you installed and then try the logo upload
    2. For the font plugin, try it with the default WP theme such as twenty thirteen and see if it works.

    When you say production server, do you mean for developing your site? IS this off your host’s server or local as on your computer?

    #19386

    Good call! It worked! I only had 4 plugins installed.
    The production server I’m talking about is my hosted server not localhost.

    I’ll play around with the Google fonts and try the same thing, maybe that will work.

    Thanks for your help.

    #19387
    Sushil Adhikari
    Moderator

    Awesome…what plugin was the culprit, or do you know? This is one of the issues of plugin development, there’s no actual coding standards and I’ve come across a lot of plugins that cause conflicts, not just with themes, but other plugins too. But hopefully the Google fonts one works; there are others you can try too.

    #19397

    Yeah, drove me crazy trying to figure it out. It was either “Dynamic Widgets”, or “Disable Comments. I think the Google fonts is OK because I installed it after I had the problem with the file download.

    Thanks

    #19398
    Sushil Adhikari
    Moderator

    More likely it will be the disable comments. But, what is important is that it sounds like you got things going.

    #19399
    Schoonbeek
    Member

    Hello,

    I also started working with Celestial ans tried everything to upload my logo and photo’s.
    But it doesn’ t work. That’s why I tried several different logo’s, but no result.

    #19400
    Schoonbeek
    Member

    When I’m uploading photo’s to the Media Library I constantly receive this message:
    Unable to create directory wp-content/uploads/2014/03. Is its parent directory writable by the server?

    #19401
    Sushil Adhikari
    Moderator

    Schoonbeek….sounds like your issue is a bit different, but it also sounds like it’s a permissions problem. You may want to search the WordPress.org forums to see if others had the same problem. I did a quick search with this as the search in Google:

    Unable to create directory wp-content/uploads

    Looks like many have that happen.

Viewing 15 posts - 1 through 15 (of 17 total)
  • You must be logged in to reply to this topic.