Comments for Blog

This topic contains 13 replies, has 20 voices, and was last updated by  Cia Williford 5 years, 9 months ago.

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #14420

    Cia Williford
    Participant

    Hi, Andre,
    Despite having the correct settings, I can’t get the comments form to show up in the blog section. Any ideas?
    http://briarwoodstudio.com/blog-2/

    #18741

    Sushil Adhikari
    Moderator

    Did you make any modifications to the theme? I just noticed the post info below the post titles has no “Comments” showing there, likewise, no comment form when viewing the full post. Something is not quite right, missing, or something wasn’t updated correctly…

    I just logged into my local test site running Celestial Reloaded 2.4.1 (which is what you are running) and I have the Comments showing under the title as well the comment form is showing.

    It’s 11:30pm here for me so I will be calling it a night but will follow up tomorrow. In the mean time, you may want to double check your settings, but also do a quick search on the wordpress.org forums for missing comments. You may also want to overwrite the theme files with a new batch of files in case you did an update but did not have all the files.

    #18743

    Cia Williford
    Participant

    The only modifications I’ve made to the child css is to add the Alex Brush font and use it to change the text logo, and I sized the content font up just a little.

    I’ve checked and rechecked my settings, so I don’t think it’s that. Will try re-uploading the theme files again. Thanks.

    #18744

    Cia Williford
    Participant

    Well, I uploaded the theme files from a clean download and that hasn’t helped, so I guess it *has* to be a setting somewhere, but damned if I can find it. Will keep looking. Thanks.

    Edited to add:
    I can create a new page, same page template, same settings, and I get the comment form. However, as soon as I make it the blog page (for posts) the comment form goes away.

    Also, I lose the page title for the blog at the same time. Don’t know if that’s intentional or not.

    #18746

    Sushil Adhikari
    Moderator

    If you changed to a different theme, does the comments label under the post title show up and also on the full post view?

    I just now installed a fresh WordPress 3.7.1 and installed Celestial Reloaded 2.4.1 and I get the “comments” show up under the post title, plus when I view the post itself, the comment form shows. I then made a custom home and blog page, did the Settings >> Reading, where I set the two pages. Same thing, I get the comment label and also the form show.

    So there must be something with your WordPress settings somewhere or perhaps a plugin that is interfering with the comments. Did you find any info searching in the WP forums about missing comment form?

    #18750

    Cia Williford
    Participant

    No, unfortunately I haven’t found anything that has helped. I’ve removed all widgets from the page, deactivated plugins, re-checked all my settings…nothing seems to touch it. I’ve already lost two days to this so I’m just going to have to live with it until I have the time (and patience) to re-do the site from the ground up. I’ve run out of things to try.

    Thanks so much for trying to help, Andre.

    #18752

    Sushil Adhikari
    Moderator

    Something is definitely odd somewhere. Did you try a different theme and did the comments show up for it? Usually to test I would switch to the WP default theme such as the Twenty Thirteen. Also, when did you notice this and did it show before?

    #18754

    Cia Williford
    Participant

    Yep, something’s off but for the life of me I can’t find it.

    I did try switching to the other themes and the comments did not show up. However, I also noticed that when I tried to use the “live preview” option under each theme, I got the left sidebar customization options and no visual, just a blank screen. *head to desk…repeatedly* I had to activate each theme in order to test it.

    #18756

    Sushil Adhikari
    Moderator

    So if the default theme is not showing comments either, then something is up with your WordPress. I’m thinking maybe download a fresh WordPress and overwrite the current files in case something was missed.

    As for the live preview…that function, sorry to be blunt here, sucks. lol…

    I did a look online and appears missing comments form is common, even dating back 6 years. But the cause seems to be random too.

    Would it be possible if to email me a login for your admin, or at the very least, a screenshot of your WordPress Settings >> Discussion screen to show your settings?

    #18757

    Cia Williford
    Participant

    New weird thing: I just posted a new blog and suddenly the comment option is there. So, what, somewhere in all my playing around I fixed it, but it didn’t show until I put up a new post? And it’s not retroactive: the earlier posts still do not allow comments. (And I don’t have the option set for disallowing comments after a post is x-many days old,either. I checked.)

    But it is semi-working now so I can live with that. I will email you the sign-in info if you want to take a look around, Andre. thanks so much for trying to help figure this out.

    P.S. If you look and you discover some really stupid thing I’ve done and didn’t notice, will you please not tell me, lol. (j/k!)

    #18758

    Sushil Adhikari
    Moderator

    OK, I won’t tell you :whistle:

    First, thanks for the login…now I know what the issue is. I clicked on the “Screen Options” tab at the top of your post editor (I opened one of your other posts) and checked the box next to “Discussion” and below the editor the option to turn off or on the comments shows now. I noticed that your older posts have the comment box unchecked, so I did the one for Shamanic…and the comments now appear.

    So…you will want to do that for your other posts. All new posts however, will automatically have this enabled.

    #18759

    Cia Williford
    Participant

    Sheesh. So it was each individual post that had them turned off? I don’t know how or why they turned out that way, but the newer didn’t.

    Thanks so much for checking, Andre. I apologize for taking up some of your time. 😳

    #18760

    Sushil Adhikari
    Moderator

    No worries… No one should have to “live with it” as you said, so I wanted to make sure that first of all it wasn’t something in my theme, but I had this little feeling, and sure enough I checked and the box was unchecked. What counts is that you now have comments enabled. Cheers!

    #14421

    Cia Williford
    Participant

    I checked and checked and checked the *page* settings, and the visible post settings, but it never occurred to me to check the screen options on the individual posts to check for comments.

    Sometimes you just have to shake your head. 😛

    Happy holidays to you, Andre. And thanks for such lovely themes to work with.

Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.