Featured image showing content of post

Home Forums WordPress Themes – Premium Encounters Featured image showing content of post

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #15034
    John Willis
    Member

    I apologize if this has been asked before but when I tried to do a search your forum only lets me go one page and the navigation to successive pages is not showing. I upgraded to the full Encounters theme today because I thought, perhaps mistakenly, that it would allow me to designate a featured image for the post but not have it show up in the the content of the post. What I would like to do is have a featured image for each posting be just the first image of the post. Right now, Feedly is pulling an arbitrary bit of code from my pages instead of any actual image (Share/Save icon which is I think from a widget). But when I try to designate one of my photos as a featured image, the page gets rewritten to add a duplicate of that featured image at the front of the posting. Since photography is a good part of my blogging effort I like to lead forth with a good image in each post. I guess I could go back a eliminate the first image of each post but that seems like an awkward way of doing it because the ‘featured image’ does not show up in my drafted posting. My main blog page is at http://www.macgardens.org.

    #19694
    Sushil Adhikari
    Moderator

    Not quite sure I fully understand what you are wanting to do…but to first clarify something, all your posts have the first image inserted directly into your post or with the featured image method?

    #19696
    John Willis
    Member

    If I choose a featured image from among the photos in the post then that image gets duplicated within the post. What I would like to be able to do is to single out an image from within the post that becomes representative of posting, either in an excerpt or in an RSS feed. Right now I don’t see how to do that without the unhelpful duplication.

    #19697
    Sushil Adhikari
    Moderator

    If i understand this correctly then, none of your posts are using the featured image; instead you have them directly inserted into your post. I did not look at all of your posts but it appears they do not have the “Continue Reading” often called a “Read More” link or button on posts in a blog,. It looks like you have the full post showing instead.

    Currently, the theme does not show the featured image on the “Full Post” view, so at the moment, using a featured image is not going to work until I do a theme update.

    One option is to insert the “read more” into your post after the first inserted image you have in a post. This would split your post where you have a summary (the first image that is inserted in your post) and then when someone clicks on the “Continue Reading” link, they will see the full post with all the images in the post.

    The other option is to use the Image Post format if you want to use a Featured Image. This will show the featured image in the blog and also on the full post view. Any image that is inserted into the post itself like you have at the moment will not show up on the blog, but the featured image will. You will still need to split your post though with the “Read More” tag from the editor.

    It appears I will need to do some updates to this theme and will have to do it this week….including updating the tutorials.

    #19707
    John Willis
    Member

    As it turns out the original problem I was dealing with, namely Feedly grabbing an icon instead of one of my photos was solved by disabling a widget and the restarting it. Now Feedly seems to reference my posts with the last photo in the post (why the last?) which is not ideal but I can live with it. I tried posting with a Featured image and Feedly doesn’t seem to care so I guess the world just doesn’t work the way I thought it should. So while I think it makes sense to me not to have a photo show up twice just because it’s a featured image, I think you can put that fix on a low priority. Thanks for the quick replies.

    #15035
    Sushil Adhikari
    Moderator

    I’m still going to be doing an update to the theme as some things are needing to be adjusted. Are you sure things are ok for now?

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.