Home page

This topic contains 10 replies, has 28 voices, and was last updated by  Anja De Dobbelaere 5 years, 9 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #14402

    Hi, thank you for answering my other questions. I have another problem, and I think I won’t be able to fix it anymore.
    When I was making my pages last week, I used the ‘blog’ page for the ‘home’. If I make a new message, then it automatically comes to the page named ‘Home’, but i don’t see that page in my dashboard with the other pages. I’m not sure if you know what I mean. I see it in my page menu but I cannot change the name ‘Home’ back to ‘Blog’ because I don’t have it in the overview of my pages. Also the three column layout does not work on that page, it does on my other pages I made.
    I hope you can tell me what to do. I would like a real homepage, like yours, with the four pictures and some text, and then the blog and some additional pages…

    #18719

    Sushil Adhikari
    Moderator

    I hope I can understand everything you said here but renaming menu items is done from the menu links which lets you edit the “labels’ of any menu link. As for the home page, blog, etc., there’s two ways:

    1. static front page where you make a new home and a blog page, then on Settings >> Reading, you set which is your front page and what is your blog page.

    2. Make sure you have a custom menu made so you can drag the pages and other things on to it, such as the home and blog pages

    3. You cannot set the page template for the blog like a standard page. It will ignore it. Only way to get a different layout is if the theme supports that option. Encounters does not have a “blog layout” option that gives you three columns. Three column layouts are for standard pages only.

    My tutorial for the demo front page is here:
    https://www.styledthemes.com/encounters-theme-setup/60-create-a-front-page-like-the-demo-site

    #18720

    Okay, so I went to settings > reading. I could not select the page called ‘Home’ because it wasn’t there.
    But it is the page where all my messages go to… as in the image 1.

    When I go to ‘pages’, that ‘home’ page is not amongst them…
    see image 2

    So what page is the page ‘Home’ then ? Is that the ‘blog’?
    Home-vs-blog.jpg
    Untitled-2.jpg

    Attachments:
    You must be logged in to view attached files.
    #18722

    Sushil Adhikari
    Moderator

    Your page is not there because it needs to be created from what I can see. Perhaps setting up a static front page tutorial is what you need to help out if you want to do a page like the demo site.

    http://codex.wordpress.org/Creating_a_Static_Front_Page

    Then make sure you have a custom menu made up (which my video tutorials helps you on this). There’s also a tutorial for the front page setup: https://www.styledthemes.com/encounters-theme-setup/60-create-a-front-page-like-the-demo-site

    #18723

    Well, the page that is called ‘home’ is actually the blog…
    I didn’t put my question very well, sorry for that.
    I actually want to change the ‘home’ to ‘blog’ and then make a new ‘home’ page, but how can I change this current ‘home’ page to ‘blog’ if I cannot find it in the pages… ?

    #18724

    Sushil Adhikari
    Moderator

    ah..ok. Then create a new page, call it “blog”, but also make sure you have another page for your “home” page too. Then make sure your Settings >> Reading, is set for the front page to be the “Home” page you have or create, then the other one for displaying posts is set to the “Blog” page you created. Then go back to your custom menu, and add the “Blog” page you created to your menu, as well make sure your “Home” page is also there. So once you do all this, you will now have a “Home” and a “Blog” menu link on your site.

    #18725

    So I cannot change the current ‘Home’ page to ‘Blog’? I’ve been posting messages there already and I’d have to redo everything…

    #18726

    Sushil Adhikari
    Moderator

    you can keep it yes…just change the label of the menu link to “Blog” and then create a new “Home” page and add it to your menu. Make sure you follow my instructions but also the ones from the WordPress site about creating a Static Front Page, because that is how you setup what you want to do. Also, you won’t lose anything either because technically, the posts are not physically in the page you made, they are assigned by WordPress when you set your settings in the Settings >> Reading options.

    #18727

    Thanks, but that was just my problem: where do I have to change the name, I cannot see the ‘home’ page in my overview of ‘all pages’…

    #18728

    Sushil Adhikari
    Moderator

    Let’s begin from the start here. But you really should follow the WordPress tutorial on setting up a Static Front page which is what you are wanting to do. But I will try to sum this up in a short version.

    1. Make sure you have 2 pages made. Make one and call it Home. Make another and call it Blog.
    2. Go to your Appearance >> Menus and make sure you have a menu created.
    3. Add the “Home” and “Blog” pages to your menu.
    4. Go to Settings >> Reading, then on the drop downs for the Front Page, select the “Home” page you made and for the posts, select the Blog page you made.

    About menus….You can rename any menu item. When you add pages or anything to a menu, it adds a default name to the label field, usually the name of the page title. But you can change the menu item’s label name. So when you add for example the “Home” page to your menu, you can change the name “Home” to whatever you want by deleting the label name and type your own to replace it.

    As a side note, you may want to check out http://www.wp101.com for WordPress tutorials. Very good video tutorials for anyone who is new to WordPRess and want to learn about the different functions of WordPress, such as menu management.

    #14403

    okay, I’ll try that all out, I’ll let you know how it goes.
    Thanks!

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.