Home Forums WordPress Themes – Premium Circumference How to disable the primary menu page link ?

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #15070

    Hi friend, thank you for help, here I want to change one thing,
    after I creat pages and add them to the menu, I have menu showing on the top,
    and with some have sub-menu pages, how can I disable the main menu page link,
    but keep sub-menu link click ?

    You know, when we have sub-menu page, the major menu page click is just too much.
    If you check my website http://www.wsw-china.com, you will understand better for my meaning,
    under the About click, I want link to sub-menu,but to the top About, I want the click to be disabled.Thank you

    Sushil Adhikari

    You need to replace the main menu link item with a custom link….create a new menu item from the “Link” option and instead of doing an http:// link, replace it with just a pound sign #

    This creates a blank link but still allows it to have submenus under it without being an actual link. Was this what you wanted to do with the menu?


    Yeah, this is what I want.

    I note, within edit format page, there’s link there, for example I see following
    Permalink: http://www.wsw-china.com/about/

    So following your instruction, I tried to change into
    Permalink: http://www.wsw-china.com/#/

    But as soon as I clink on the ok button, the link appears like following:
    Permalink: http://www.wsw-china.com/12-2/

    Did I do any thing wrong ? Thank you.

    Sushil Adhikari


    …should be this:



    Thank you my friend….


    I test the website, actually what I prefer, when the mouse move over the top menu text,for example ABOUT,
    there will not be any link actually, but with below sub-menu showing up. Can I make some code in the child theme ?
    Will this be a big job ?


    I find the answer already, once I remove all the items within link option, things are just fine.

    Thank you for your help. Have a nice day!

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.