Menus in iOS

Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts
  • #15658
    Richard Gregson
    Participant

    The drop down menus do not function in iOS (on an iPad). Other Styled Themes themes seem to be OK so presumably this is an easy fix.

    Any suggestions?

    #20698
    Anonymous
    Inactive

    Just tested demo site in iPad and it works fine. Below is attached screenshot. Can you give us the url of your demo site where it’s not working ?

    Thank you !
    IMG_0275.png

    Attachments:
    You must be logged in to view attached files.
    #20699
    Richard Gregson
    Participant

    The URL is http://sparroworks.ca/wildlifing/

    A couple of the main menu items have child pages that should drop down when hovered over and they don’t

    #20700
    Aki Christina
    Participant

    Same here. In the latest Firefox only a bullet-list appears and on an older version of chrome the mobile menu ICON and the bullet-list appear. Same fault on IE and on Smartphone Galaxy S2. 🙁

    Same issue on my own site and on sparroworks.

    #20701
    Richard Gregson
    Participant

    I just tried my site in on an iPad using Chrome as the browser and that does partially work as expected in as much as the drop down options appear but they are not active. The original problem for me was with Safari where nothing even drops down … And as that is the default iOS browser it’s quite a problem

    #20702
    Anonymous
    Inactive

    @Aki – Can you post your site too ? So we can check it.


    @Richard
    – Well there seems to be js error when i checked in Firebug which might be causing the issue. Can you try to disable all the plugin and see if it helps or not.

    In the meantime, We’ll try to generate the issue and fix it.

    #20706
    Richard Gregson
    Participant

    Roshan – deactivating plugins made no difference

    #20709
    Anonymous
    Inactive

    Dear Richard,

    Yes we figured out that this is a bug and we will fix it soon and push a new version of Pure & Simple.

    Thank you !

    #20716
    Anonymous
    Inactive

    @Richard and @Aki. – We’ve released the new version 1.0.2 which should fix this issue. Please let us know how it goes.

    #20717
    Aki Christina
    Participant

    🙂 Works on latest IE, FF and Samsung Galaxy S2
    🙁 on Chrome, Version 39.0.2171.71 m, the mobile menu button does not drop down.

    #20718
    Richard Gregson
    Participant

    Works fine on regular Mac (OS X Yosemite) but still does not work on iOS (iPad) … in Safari the drop down menus do not “drop down”, in Chrome they do but they are not functioning.

    #20719
    Anonymous
    Inactive

    @Aki – Are you referring to Chrome, Version 39.0.2171.71 on Samsung Galaxy S2 ? Can you post your url too please.


    @Richard
    – I’m going to grab iPad tomorrow and test it again. But can you post the screenshot specially on chrome what exactly you meant by not functioning.

    Do you both see the same problem on the demo or not ? http://demo.styledthemes.com/demos/puresimple/

    Let us know that.

    Thank you !
    localization.jpg

    Attachments:
    You must be logged in to view attached files.
    #20728
    Richard Gregson
    Participant

    @Roshan
    Attached are two screen shots

    IMG_0065 is from Safari on the iPad. A menu top item is selected (and the page is served) but the drop down menu listing pages below that option are not shown at all

    IMG_0067 is from Chrome on the iPad. The subservient pages do drop down but when selected/clicked on nothing happens, they do not serve the requested pages.

    Richard
    IMG_0065.png
    IMG_0067.png

    Attachments:
    You must be logged in to view attached files.
    #20737
    Anonymous
    Inactive

    Thank you Richard those are very valuable information. I can generate exact exact test case as it seems to be happening when your top level menu don’t have ‘#’ in href . That’s why it was working in our demo site and not in yours.
    For the quick fix, create the menu with top level menu has # in href and make it primary menu.

    We’ll fix the the bug and post the new version asap.

    Thank you !

    #20740
    Anonymous
    Inactive

    We’ve uploaded the new version of Pure & Simple pro theme it should fix the problem of yours. And if you’re still having problem and using the child theme make sure you follow the step on the release note to invalidate the cache.

    Let us know how it goes.

Viewing 15 posts - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.