New Blog Page Not Showing

Home Forums WordPress Themes – Premium Pure & Simple New Blog Page Not Showing

This topic contains 9 replies, has 2 voices, and was last updated by  Bidur 1 year, 11 months ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #51958

    Tish
    Participant

    I have a static front page, a Blog page, About page, etc. I make edits using the child theme.

    I published my first blog post. Then I added (published) a second post the same way: Post ==> Add New

    But the second post doesn’t show up on the BLOG page when I view my site. The only post is the first one.

    –Why is this happening? How do I fix it?
    –Also, I don’t want my posts to have a date. How do I prevent dates on my posts?

    If I get any instruction to add code to a css style sheet, please clarify if that css location would be: Appearance ==> Menu ==> Additional CSS?

    Thanks

    #51981

    Tish
    Participant

    I’ve tried to fix this issue and it’s still not working. To recap: I have a static front page, a Blog page, About page, etc. I make edits using the child theme.

    I checked SETTING => READING: Front page displays a Static Page. In the drop down menu-
    Front page is HOME
    Post page is BLOG

    I had initially added the first post under the BLOG page, but after researching I discovered this was a mistake and it should remain empty. So I deleted the content under the Blog page and kept the Blog page itself. I ADDED the two posts under the Post ==> Add New . The posts are still not displayed on my website. Now the Blog page has the words “Nothing Found.”

    This is very frustrating. Especially since the tutorials don’t give any troubleshooting tips and there’s no search field on these forums to find your particular issue. Instead, you have to sift through pages and pages and pages and pages of issues.

    If I get any instruction to add code to a css style sheet, please clarify if that css location would be: Appearance => Menu => Additional CSS?</strong? Or Appearance => Edit CSS ?

    #51987

    Bidur
    Moderator

    Hello Tish,

    Have you checked into Dashboard>>Posts>>All Posts>> Your Post>> quick edit>> status ? Make it published if saved as draft.
    Also edit the permalink for post inside setting>> Permalinks.

    Let us know.
    Thanks!

    • This reply was modified 1 year, 11 months ago by  Bidur.
    #51994

    Tish
    Participant

    Hi,

    For solution #1 – I published the post already. So it is set to publish. I checked it again and it is still set to publish. But the post doesn’t show up on my blog still. I set it to draft, saved then set it to publish again and saved. It still doesn’t show up on my blog.

    For solution #2 – How should the permalink read after I edit it?

    These blog posts still aren’t showing up. Are there other solutions?

    #52000

    Bidur
    Moderator

    Hello Tish,

    Go to Settings>>Permalinks and choose Post name as common settings.
    OR edit the slug inside your post>>edit>>edit the permalink and then update.
    Have you also checked if there are any conflicting plugins, server issues or tried clearing the cache? Please try if not.

    Let us know if it works!

    Best regards,
    Bidur

    #52013

    Tish
    Participant
    This reply has been marked as private.
    #52019

    Bidur
    Moderator

    Yes, Please share us your site url so we could track the issue promptly.

    Best Regards,
    Bidur

    #52034

    Tish
    Participant
    This reply has been marked as private.
    #52052

    Bidur
    Moderator

    Hello Tish,

    Strange! Everything should have worked fine .
    Would you mail us your back-end login details(wp-admin login details)?

    Best Regards,
    Bidur

    #52061

    Bidur
    Moderator

    Hello Trish,

    You have added me user but as editor only so I cant access any other main features in dashboard. And also please don’t send username and password in forum. For this you can send in email. [email protected].

    1. This page not found is showing as you have to select blog page as post page. You can do if from Dashboard > setting > reading.
    2. For Custom Links there is option in menu Dashboard > appreance > Menu then add custom link and link it to any page you like and add in menu.
    3. Removed the date part of blog as you said.

    If you have further questions please contact us.
    Thanks

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.