Page Jumps with Sticky Menu

Home Forums WordPress Themes – Premium Circumference Page Jumps with Sticky Menu

Viewing 15 posts - 1 through 15 (of 20 total)
  • Author
    Posts
  • #17059
    Francois Zietsman
    Participant

    Hi, When I switch the sticky menu on, the page jumps and does not scroll to the bottom – I find this happening if the page does not have too much content.

    It happens on these pages for example:

    http://www.multiseal.co.za/composition

    How can I fix this please?

    Thanks

    #22444
    Sushil Adhikari
    Moderator

    Hi Francois Zietsman,

    Sorry for the inconvenience , we already came to version 2.1.0, so please update to latest version , it may solve your issue.

    Here in the tutorial we have take flat responsive as an example, you can applied same for your theme.
    https://www.styledthemes.com/wordpress-tutorials/410…ling-updating-themes

    If you got any problems on this please don’t hesitate to reach back out to us. We will be more than glad to assist you

    Note: Please take a backup of your site before proceeding so you will be in position to take action when disaster strikes.
    . Normally we use duplicator plugin to make a backup.https://wordpress.org/plugins/duplicator/.

    Here is the video tutorials how to use duplicator and save it to your local computer https://www.youtube.com/watch?v=VdvOGV2eIjE

    Thanks

    #22446
    Francois Zietsman
    Participant

    Hi Sushil

    Thank you. I have updated the theme as explained here on the update section: https://www.styledthemes.com/wordpress-tutorials/410…ling-updating-themes

    I used the Circumference Child Theme (Ver. 1.0.0) on the previous design

    1. I activated Twenty Sixteen
    2. Deleted the old Circumference
    3. Uploaded the newest version 2.1.0
    4. Re-activated the old child theme

    My pages still jumps, and I can’t remove the child as all my customizations will be missing

    Where can I email you personal login details so that you can maybe have a look?

    Thanks

    #22447
    Sushil Adhikari
    Moderator

    We had checked all your seven pages , but we didn’t see any jumping pages. So could you please provide us specific pages where you encounters the issue:
    So it will be easy for both of us to find appropriate solution .

    And also you add this css on child theme style.css file , it may help you.

    div#cir-content-wrapper {
        min-height: 500px;
    }

    Let us know how it goes.

    Looking forward for your response.

    Thanks

    #22449
    Francois Zietsman
    Participant

    Hi Sushil

    Thank you for the quick reply. I find it still jumping on these pages:

    1. http://www.multiseal.co.za/composition/
    2. http://www.multiseal.co.za/uses-and-benefits/
    3. http://www.multiseal.co.za/waterproofing-products-for-waterproofing-contractors/
    4. http://www.multiseal.co.za/contact-us/

    I am using Google Chrome as well as Firefox. Jumps on both browsers using a 27″ Monitor (1920 x 1080px)

    Thanks

    #22450
    Sushil Adhikari
    Moderator

    It seems you have short content area show sticky menu doesn’t get proper space to scroll, so please increase min height of content area , it will solve your issue:

    div#cir-content-wrapper {
        min-height: 700px !important;
    }
    #22453
    Francois Zietsman
    Participant

    Sorry, but it still jumps even with your suggestion – I even increased it to 900px but still jumps.

    According to me on lots of other themes I have used, the height of the content should not have anything to do with the sticky menu. It should still work. And on this page for example (http://www.multiseal.co.za/composition), there is a lot of space to still scroll, but it jumps. See attachment

    I even increased your suggestion to 900px, and it still jumps
    StickeyMenu.jpg

    Attachments:
    You must be logged in to view attached files.
    #22454
    Sushil Adhikari
    Moderator

    Could you please add those css given on previous reply and provide us link. Actually we didn’t see those code on your site.

    So please add those css and let us know about that.

    Thanks

    #22455
    Francois Zietsman
    Participant

    Hi Sushil

    I added it to the child theme (Editor) as can be seen on the attachment.

    http://www.multiseal.co.za/composition/
    http://www.multiseal.co.za/uses-and-benefits/

    And other pages still jumps

    Thanks
    CustomCSS.jpg

    Attachments:
    You must be logged in to view attached files.
    #22456
    Sushil Adhikari
    Moderator

    Hi Francois Zietsman

    We are really sorry for the inconvenience, here we are not getting any jumping pages on your site. So could you please clear cache and try again , that may solve your issue. Due to the cache, browser may not take your changes on style.css file

    If still you got any problems on this, lets discuss on live chat.

    Thanks

    #22459
    Francois Zietsman
    Participant

    Hi Sushil

    Thanks, I did clear the browsers, and used Chrome and Firefox but still jumping on those pages – as soon as I switch the sticky menu off, it stops with the page jumping.

    My screen resolution is 1920 x 1080px (27″ Monitor)

    Attached is a video recording showing the pages jump. On the home page and the products I can scroll to the bottom without any problems, but on the other pages you will see I can’t go to the footer then it jumps back to the top.

    Thanks

    #22460
    Sushil Adhikari
    Moderator

    Please remove the css given on previous reply and add this on child theme style.css

    div#cir-content-wrapper {
        min-height: 100vh !important;
    }

    Thanks

    #22462
    Francois Zietsman
    Participant

    Thanks, It worked but now I have some massive white spaces below on the pages which look terrible and not worth it.

    Is there nothing that can be done with the sticky menu itself?

    Even this $8 theme has a sticky menu which works perfectly on pages with short content areas… http://www.pre-mcorp.co.za/about-enterprise-and-supplier-development

    Otherwise I will just switch off the sticky menu if this can’t be fixed another way – the white spaces makes it look unfinished.

    Thanks

    #22463
    Sushil Adhikari
    Moderator

    Hi Francois Zietsman,

    We are really sorry for the trouble , you can try by reducing the value of min-height so that your white spaces will be reduced and sticky menu also works.

    div#cir-content-wrapper {
        min-height: 70vh !important;
    }

    If this doesn’t works for you please provide you wp-login details at our [email protected]s.com

    Thanks

    #22464
    Francois Zietsman
    Participant

    Hi Sushil

    Thanks, but on 70vh the page jumps again and has some white space also which does not look good.

    But don’t worry, I just kept it at default (removed all custom css) and disabled the sticky menu.

    I will in any way send you admin login to [email protected] so that you can have a look, maybe you can figure something out.

    Thanks

Viewing 15 posts - 1 through 15 (of 20 total)
  • You must be logged in to reply to this topic.