Pages have vanished from header

Home Forums WordPress Themes – Premium Styled Store Pro Pages have vanished from header

This topic contains 9 replies, has 2 voices, and was last updated by  Sushil Adhikari 2 years ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #47723

    EDWARD RUBIO
    Participant

    Just recently all my pages vanished from the header completely when viewing from a desktop browser. If in mobile view, it shows in the expanded menu, but somehow has just vanished from view when in a desktop browser.

    I’ve completely deleted the theme and uploaded a fresh copy, but it still follows.

    #47724

    Sushil Adhikari
    Moderator

    Dear Edward,

    Styled Store comes with separate menu location for desktop and mobile menu. Primary menu is meant for deskstop wheras mobile menu is only meant for mobile. For this you can go to:

    Go to dashboard -> Appearance -> select you menus -> scroll down and you will get menu setting -> assign to specific menu location:
    http://prntscr.com/ftq8jh

    Let us know if this provides you a solution otherwise please provide us your site url with proper screenshot. So we can provide you a appropriate solution.

    Thanks

    #47746

    EDWARD RUBIO
    Participant

    Thanks for the info. Seems some stuff was not set up correct, but appears that did not solve the issue. If you look at the attached images you will see the missing options, and the menu settings. I may be missing something, or using the improper verbage when saying “menu” – but it used to list all pages by default under the title and subtitle of the page.

    • This reply was modified 2 years, 2 months ago by  EDWARD RUBIO.
    Attachments:
    You must be logged in to view attached files.
    #47787

    Sushil Adhikari
    Moderator

    Hi Edward,

    Could you please attached your site url so we can provide you appropriate solution.

    We had gone quick look through the screenshot and we assume your header background color is dominating menu color. So it seems your menu to be hidden. So we recommend you to change color of menu container and menu. For this:

    Go to dashboard -> Appearance ->? customizer ->Header setting -> change color from Menu container color & Header Navigation Menu Color options.

    Also you can find many more options for this, please go through all the options.

    We look forward for your response.

    Thanks

    #47796

    EDWARD RUBIO
    Participant

    Hello Sushil,

    Thanks for your assistance so far!

    I thought that may have been the issue at first, but the cursor doesnt change when you mouse over.

    The site URL is https://www.SpoolThreadCo.com

    Any further help is appreciated!

    #47799

    Sushil Adhikari
    Moderator

    Hi EDWARD RUBIO,

    Sorry for the inconvenience caused, we had updated child theme to version 1.0.2. If you have not add any code on to child theme, then you can simply update your child theme to latest version.

    If some changes are made on child theme then please follow the following steps:

    If you are technically sound on WordPress, please change the following code on functions.php other wise please send us your wp-admin details on [email protected] , we will do that for you.

    On child theme wp-content/themes/styledstore-child -> functions.php file( You can view this file structure from FTP ) you will find this following code:

    
    add_action( 'wp_enqueue_scripts', 'theme_enqueue_styles', 100 );
    function theme_enqueue_styles() {
    
        wp_dequeue_style( 'styledstore-pro-style' );
        wp_enqueue_style( 'parent-style', get_template_directory_uri() . '/style.css' );
        wp_enqueue_style( 'child-style', get_stylesheet_directory_uri() . '/style.css' );
    
    }

    Replace above code with this code:

    
    add_action( 'wp_enqueue_scripts', 'styledstore_child_enqueue_styles', 100 );
    function styledstore_child_enqueue_styles() {
    
        wp_dequeue_style( 'styledstore-pro-style' );
        wp_dequeue_style( 'styledstore-pro-responsive-csss' );
        wp_enqueue_style( 'styledstore-parent-style', get_template_directory_uri() . '/style.css' );
        wp_enqueue_style( 'styledstore-responsive', get_template_directory_uri() . '/css/responsive-css.css' );
        wp_enqueue_style( 'styledstore-child-style', get_stylesheet_directory_uri() . '/style.css' );
    
    }

    Please keep back up of your website before proceeding this, so you can take a action when disaster strikes.

    Thanks

    #47815

    EDWARD RUBIO
    Participant

    Thanks! This seems to sorta have solved it. Now if I disable the menu (as it was before) I get the page listings again, but now its under the sub-title rather than next to it.

    If I enable the menu again – I get the same outcome, but with a search bar now.

    In either scenario, there seems to be a border on each side too. (if you go to the site you can see this).

    Sorry for the filtered photo, its the only I could find of the site prior to this update – but this is what the header/menu looked like before – is it possible to get it to looking that way again?

    Attachments:
    You must be logged in to view attached files.
    #47821

    Sushil Adhikari
    Moderator

    Dear EDWARD RUBIO,

    Thank you for your cooperation, we really appreciate it.

    If you didn’t assign menus to any menu location, then primary menu by default will list all the pages. We had visited your website and menus looks fine.

    Also if you assign menu location to primary then product search will append with menu. You can easily create the menu as shown on demo site and as per your screenshot.

    Please do provide screenshot stating your issue clearly.So we can help you appropriately.

    If you are getting hard time on structuring menu please do folllow this article

    Best Regards

    #49123

    EDWARD RUBIO
    Participant

    Everything is fine at this time. I was on a smaller monitor that was forcing the menu to appear like that.

    Thanks for all the help, really appreciate it!

    #49140

    Sushil Adhikari
    Moderator

    Thank you Edward for letting us know. We are happy to help you.

    Thanks

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.