PHP 7.0 Upgrade causing Error Messages

Home Forums WordPress Themes – Premium Celestial (Celestial Reloaded) PHP 7.0 Upgrade causing Error Messages

This topic contains 2 replies, has 2 voices, and was last updated by  Pete Ciliberto 2 months, 2 weeks ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #59612

    Pete Ciliberto
    Participant

    When I upgraded my site to PHP 7.0, I received the following error messages related to the Walker Nav Menu…

    Warning: Declaration of styledthemes_nav_walker::start_lvl(&$output, $depth) should be compatible with Walker_Nav_Menu::start_lvl( &$output, $depth = 0, $args = Array ) in /home2/reinspec/public_html/wp-content/themes/st_celestial_child/inc/nav-menu-walker.php on line 109

    Warning: Declaration of styledthemes_nav_walker::start_el(&$output, $item, $depth, $args) should be compatible with Walker_Nav_Menu::start_el( &$output, $item, $depth = 0, $args = Array, $id = 0 ) in /home2/reinspec/public_html/wp-content/themes/st_celestial_child/inc/nav-menu-walker.php on line 109

    Can you please provide me with the proper code to edit the inc/nav-menu-walker.php file? Thnak you in advance for your help.

    #59624

    Bidur
    Moderator

    Hello Pete,

    Could you please locate it on your website?

    Thanks!

    #59625

    Pete Ciliberto
    Participant

    As noted in my initial request the code error is in the wp-content/themes/st_celestial_child/inc/nav-menu-walker.php on line 109. My website is re-inspect.com
    Thanks for your help. Please let me know if you need anything else.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.