Prevent indexing of author pages

Home Forums WordPress Themes – Premium Preference Prevent indexing of author pages

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #14050
    Goran
    Participant

    I noticed that Google indexed http://www.sitename/author/admin/ page. I don’t want such a page to be indexed as am the only author of the content so this is not necessary. How do I stop search engine from indexing author page or how I just get rid of the author pages compeltely?

    #18197
    Sushil Adhikari
    Moderator

    you will need to manage the robots.txt file which is dynamically generated in WP. But there’s lots of plugins to do this, for example: http://wordpress.org/plugins/wordpress-meta-robots/

    Plus, there’s seo plugins too.

    #18201
    Goran
    Participant

    Yes, that is the third option. Probably the simplest. Didn’t occur to me. Already using robots.txt. I could probably even redirect it. Would this be the correct parameter /wp-content/themes/preference/author.php? Am not sure if am suppose to block specific .php and if this one is the php.

    But if I wanted to destroy all references to above URL so the page doesn’t exist, I would presumably need to delete some lines from which .php file?

    #14051
    Sushil Adhikari
    Moderator

    That, I’m not sure of because WordPress does everything slightly different from what I’m used to. You may want to do some forum search or on Google how to block pages with robots.txt on WordPress.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.