Translation

This topic contains 5 replies, has 9 voices, and was last updated by  Thomas Engeroff 3 years, 3 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #13542

    Thomas Engeroff
    Participant

    Hi,

    one of my clients is running the Luminescence-Theme and he needs a full translation, e.g. in the post the text “published by…” should be displayed in german. Is this text from the theme or coming from wordpress istself? And, can you recommend a translation-plugin?

    Kind Regards
    Tom

    #23070

    Binaya D
    Participant

    Hi Thomas,

    You can use the google translation plugin or you can use the pot file which kept inside the language folder of theme file. And about published by it is from the theme, so you can translate it also. We hope this will be helpful to you, if not then please let us know.

    Thanks

    #23077

    Thomas Engeroff
    Participant

    Hi,

    its not working as hoped: I translated the .pot-file in /…/wp-content/themes/luminescence/languages, but the translation is not applied.

    Have a look (at the bottom of the content): http://archenoris.net/neues-aus-moosach/

    Can you re-check? The language is set to “Deutsch” (German).

    Thanks
    Tom

    #23078

    Binaya D
    Participant
    #23079

    Thomas Engeroff
    Participant

    Hi,

    the related files are in the folder …../wp-content/languages/themes. (not in the theme folder)

    There are some .mo files, for Luminesscence in german the file needs the format luminescence-de_DE.mo

    Even when deleting the .pot file under …/wp-content/themes/luminescence/languages, the translation remains visible an intact.

    Regards
    Tom

    #13541

    Sushil Adhikari
    Moderator

    Hi Thomas Engeroff,

    Please make sure of following steps:
    1> You need to place whole po and mo file generated from poedit, [ click here for poedit tutorial ] there inside theme folder:
    site-folder->wp-content->themes->luminescence->languages
    2> Then be sure you can find you translated string for specific string on po files
    3> Be sure you are using file with prefix is de_DE
    4> Finally select the language from site language section. Go here:
    Go to dashboard -> settings -> Genearal -> Site Language [ Duetch ]

    Let us know if those steps help you on this. and also we had provided you the reference links on previous reply, please go through all this.

    Hope this work for you.

    Thanks

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.