Widgetkit gallery accepts no child theme style

Home Forums WordPress Themes – Premium Celestial (Celestial Reloaded) Widgetkit gallery accepts no child theme style

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #14302
    Aki Christina
    Participant

    Good morning :cheer:

    I am using a child theme for Celestial Reloaded. Normally, when style changes are not accepted, I use the !important tag and it works fine.

    Now I want to apply changes to the Widgetkit Gallery (borders around the tn), but even with !important no changes appear. Browsercache etc. is cleared and I tested in two browsers.

    My child entry:

    
    
    /* Widgetkit Gallery */
    
    .st_wkgallery-tn {
    
    	padding: 0.4em!important;
    	background-color:#973800!important;
    	border:1px solid #e6e6e6!important;
    }

    Tried without !important, with !important, with and without space between e.g. color and !important …

    🙁 can’t see my fault and need help.

    Link: http://hydrofotografie.de/donaukraftwerk-friedingen/ (scroll down to “Videos”)

    Thank you!
    Aki Christina

    #18551
    Sushil Adhikari
    Moderator

    I just setup a sample page with your video gallery and used the child theme with your styling shown above and I got it to work with a nice rust coloured border. Where precisely did you add your code in the child theme style.css ? Does it look like this:

    /* Add your style.css changes below the line
    -------------------------------------------------------------- */
    .st_wkgallery-tn {
    	padding: 0.4em;
    	background-color:#973800;
    	border:1px solid #e6e6e6;
    }

    Note: For the above, you actually don’t need the !important…although it was great you thought about that and how it works.

    Also, I noticed you do not have the child theme active, which would be the issue as well. For any overrides in the child theme style.css, you need that one active and the parent theme deactivated.

    #18553
    Aki Christina
    Participant

    Thank you for quick reply.

    I use a child theme :silly: Well, I think so.

    My child stlye.css is this one, and the other changes are apllied correctly:

    /*
    Theme Name: Celestial Child
    Theme URI: http://demo.styledthemes.com/celestial
    Description: Celestial Child is created for you to take advantage of making changes to the parent theme of Celestial without actually changing its files, you will do your customization from this child theme of Celestial.
    Template: celestial
    Version: 0.1.0
    Author: StyledThemes.com
    Author URI: http: //www.styledthemes.com/
    Tags: dark, light, gray, white, one-column, two-columns, three-columns, right-sidebar, flexible-width, custom-background, custom-header, custom-menu, editor-style, featured-images, full-width-template, post-formats, sticky-post, theme-options, translation-ready
    
    License: GNU General Public License v3 or later
    License URI: http://www.gnu.org/licenses/gpl-3.0.html 
    
    Encounter WordPress Theme, Copyright (C) 2013 Andre Jutras
    
    
    This theme, like WordPress, is licensed under the GPL.
    Use it to make something cool, have fun, and share what you've learned with others.
    */
    
    /* Imported Styles from Celestial
    -------------------------------------------------------------- */
    @import url('../celestial/style.css');
    
    /* Add your style.css changes below the line
    -------------------------------------------------------------- */
    .main-navigation ul li:hover > ul {
    		border-bottom: 6px solid #BCC0C3 !important;
    }
    
    /* Überschriften */
    h1 {
        font-size: 1.9em;
    }
    h1, h2, h3, h4, h5, h6 {
    	font-family: arial, helvetica, sans-serif;
    }
    
    
    /* Navigations Menü */
    
    .main-navigation li {
    	font-family: verdana,arial,helvetica,sans-serif;
             font-size: 0.94em;
    }
    
    /* Höhe der linkbox */
    
    .main-navigation li a {
        line-height: 3;
    }
    
    /* make the main level menu items active with a colour */
    	.main-navigation .current-menu-item > a,
    	.main-navigation .current-menu-ancestor > a,
    	.main-navigation .current_page_item > a,
    	.main-navigation .current_page_ancestor > a {
    		font-weight:normal;
    
    
    /* Widgetkit Gallery */
    
    .st_wkgallery-tn {
    
    	padding: 0.4em!important;
    	background-color:#973800 !important;
    	border:1px solid #e6e6e6!important;
    
    }
    
    
    /* mobile styling 
    -------------------------------------------------------------- */
    
    @media (min-width: 768px) and (max-width: 979px) {
    }
    
    @media (min-width: 1200px) {
    }
    
    @media (max-width: 979px) {
    }
    
    @media (max-width: 767px) {
    }
    
    @media (max-width: 480px) {
    }
    
    @media (max-width: 320px) {
    }

    Can Template: celestial be the error? Might it be Template: Celestial Reloaded? Used the one you provided in the download folder.
    But still do not understand why the other changes work fine.
    How do you see that no child is active?

    🙂
    celestial_child.gif

    Attachments:
    You must be logged in to view attached files.
    #18555
    Sushil Adhikari
    Moderator

    I seriously need a vacation or more sleep, lol. You are correct. Anyway, the problem is that you have no closing curly bracket after your font-weight: normal;

    		font-weight:normal;
    
    This is where the closing curly bracket should be
    
    /* Widgetkit Gallery */
    #14303
    Aki Christina
    Participant

    seriously need a vacation or more sleep, lol.

    😆 same to me … :whistle:

    Thanks a lot, works fine now.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.